aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-05-04 15:09:56 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-05-04 15:09:56 +0200
commit74ee30f7ea60054196f1f6068f0f98f163159e9d (patch)
tree0daeac2b2d6b92ee43ba882d97cc708ca1c59788 /src/Makefile.am
parent4b2c5174eed10ba5d342face4975b209badf81b8 (diff)
downloadlibpam-x2go-74ee30f7ea60054196f1f6068f0f98f163159e9d.tar.gz
libpam-x2go-74ee30f7ea60054196f1f6068f0f98f163159e9d.tar.bz2
libpam-x2go-74ee30f7ea60054196f1f6068f0f98f163159e9d.zip
include/pam-x2go.h: Move login prompt strings into public include file, so it can be used by e.g. Arctica Greeter.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e09c057..49d5639 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,3 +1,5 @@
+NULL =
+
pamlibdir = $(PAMMODULEDIR)
pamlib_LTLIBRARIES = pam_x2go.la
@@ -17,9 +19,18 @@ pam_x2go_la_CFLAGS = \
-DAUTH_CHECK="\"$(libexecdir)/x2go-auth-check\"" \
$(COVERAGE_CFLAGS)
+pam_x2go_la_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ $(NULL)
+
pam_x2go_la_LIBADD = \
-lpam
+pam_x2goincludedir = $(includedir)/security/
+pam_x2goinclude_HEADERS = \
+ $(top_srcdir)/include/pam-x2go.h \
+ $(NULL)
+
libexec_PROGRAMS = \
x2go-auth-check