aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-09-19 16:59:53 -0500
committerTed Gould <ted@gould.cx>2012-09-19 16:59:53 -0500
commita2d6c7eed22dafba1350d97471304d30046b99cc (patch)
treeea145b4ea1a14ab3fd17899f8835c80260a69e7b /tests/Makefile.am
parentd7705fcc79144eb895a8ebc04dd5561f3c8afd70 (diff)
downloadlibpam-x2go-a2d6c7eed22dafba1350d97471304d30046b99cc.tar.gz
libpam-x2go-a2d6c7eed22dafba1350d97471304d30046b99cc.tar.bz2
libpam-x2go-a2d6c7eed22dafba1350d97471304d30046b99cc.zip
Adding a small auth check utility
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4e51e62..b7c39f0 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -3,9 +3,11 @@ DISTCLEANFILES =
EXTRA_DIST =
TESTS = \
- test-freerdpclient-wrapper
+ test-freerdpclient-wrapper
-check_PROGRAMS = $(TESTS)
+check_PROGRAMS = \
+ test-freerdp-auth \
+ $(TESTS)
AM_CPPFLAGS = $(GTEST_CPPFLAGS) \
$(REMOTE_APPS_MANAGER_CFLAGS) \
@@ -37,6 +39,8 @@ libgtest_a_CXXFLAGS = \
# Wrapper
##########################
+test_freerdp_wrapper: test-freerdp-auth
+
test_freerdpclient_wrapper_SOURCES = \
mock_pam.c mock_pam.h \
mock_guest.c mock_guest.h \
@@ -53,3 +57,10 @@ test_freerdpclient_wrapper_CXXFLAGS = \
test_freerdpclient_wrapper_LDFLAGS = \
-pthread
+##########################
+# Auth tool
+##########################
+
+test_freerdp_auth_SOURCES = \
+ test-freerdp-auth.c
+