aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am65
1 files changed, 65 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..e687799
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,65 @@
+CLEANFILES =
+DISTCLEANFILES =
+EXTRA_DIST =
+
+TESTS = \
+ test-auth-check \
+ test-icaclient-wrapper
+
+check_PROGRAMS = $(TESTS)
+
+##########################
+# Google Test Test Suite #
+##########################
+check_LIBRARIES = libgtest.a
+
+AM_CPPFLAGS = $(GTEST_CPPFLAGS) \
+ $(REMOTE_APPS_MANAGER_CFLAGS) \
+ -I${top_srcdir}/src -Wall -Werror
+AM_CXXFLAGS = $(GTEST_CXXFLAGS) \
+ $(REMOTE_APPS_MANAGER_CFLAGS)
+
+AM_CFLAGS = \
+ -Wall \
+ -g
+
+nodist_libgtest_a_SOURCES = \
+ $(GTEST_SOURCE)/src/gtest-all.cc \
+ $(GTEST_SOURCE)/src/gtest_main.cc
+
+libgtest_a_CPPFLAGS = \
+ $(GTEST_CPPFLAGS) -w \
+ $(AM_CPPFLAGS)
+libgtest_a_CXXFLAGS = \
+ $(AM_CXXFLAGS)
+
+test_auth_check_SOURCES = \
+ test-auth-check.cc
+
+test_auth_check_LDADD = \
+ $(top_builddir)/src/pam_ica.la \
+ libgtest.a
+
+test_auth_check_CXXFLAGS = \
+ $(AM_CXXFLAGS) \
+ -I${top_srcdir}/src
+
+test_auth_check_LDFLAGS = \
+ -pthread
+
+test_icaclient_wrapper_SOURCES = \
+ mock_pam.c \
+ mock_guest.c \
+ test-icaclient-wrapper.cc
+
+test_icaclient_wrapper_LDADD = \
+ $(top_builddir)/src/pam_ica.la \
+ libgtest.a
+
+test_icaclient_wrapper_CXXFLAGS = \
+ $(AM_CXXFLAGS) \
+ -I${top_srcdir}/src
+
+test_icaclient_wrapper_LDFLAGS = \
+ -pthread
+