summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2019-01-22 16:12:29 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2019-01-22 16:12:29 +0100
commit5aa4cf05ee3182cf06ccfdf1def96817f0f80eaf (patch)
tree3be7711d6e1412582fc2aa85a86935cb9c8f1589 /Makefile.am
parent5668efb3181ba6a5465a0278517b1430dc79982b (diff)
downloadlibrda-5aa4cf05ee3182cf06ccfdf1def96817f0f80eaf.tar.gz
librda-5aa4cf05ee3182cf06ccfdf1def96817f0f80eaf.tar.bz2
librda-5aa4cf05ee3182cf06ccfdf1def96817f0f80eaf.zip
Support 'make distcheck'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c655e5a..c7848ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,16 +1,25 @@
+NULL =
+
SUBDIRS = data src util po
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
if WANT_TESTS
-SUBDIRS += \
- tests
+SUBDIRS += \
+ tests \
+ $(NULL)
tests: librda
endif
+DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-x2go \
+ --enable-ogon \
+ --disable-silent-rules \
+ --enable-introspection \
+ $(NULL)
MAINTAINERCLEANFILES = \
$(srcdir)/aclocal.m4 \