summaryrefslogtreecommitdiff
path: root/util/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2019-01-19 00:28:15 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2019-01-19 00:33:38 +0100
commit5ae2fca60a84a929fca55131d5c1b486d1e68015 (patch)
treeadf84def9c85de7c7349ffe29556425ee2f66b64 /util/Makefile.am
parent74e8e01c459f7fbf8eb5e91362c41c6557f0fe00 (diff)
downloadlibrda-5ae2fca60a84a929fca55131d5c1b486d1e68015.tar.gz
librda-5ae2fca60a84a929fca55131d5c1b486d1e68015.tar.bz2
librda-5ae2fca60a84a929fca55131d5c1b486d1e68015.zip
rdacheck: Add little tool that reports about what RDA detects.
Diffstat (limited to 'util/Makefile.am')
-rw-r--r--util/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/util/Makefile.am b/util/Makefile.am
new file mode 100644
index 0000000..8d1d792
--- /dev/null
+++ b/util/Makefile.am
@@ -0,0 +1,23 @@
+NULL =
+
+RDA_LIB = -lrda
+
+DISTCLEANFILES =
+
+bin_PROGRAMS = rdacheck
+
+rdacheck_SOURCES = \
+ rdacheck.c
+
+rdacheck_CFLAGS = \
+ -Wall -Werror \
+ $(LIBRDA_CFLAGS) \
+ -I$(top_srcdir)/src/ \
+ -DBUILD_DIR="\"$(builddir)\"" \
+ $(NULL)
+
+rdacheck_LDADD = \
+ $(RDA_LIB) \
+ $(LIBRDA_LIBS) \
+ -L$(top_builddir)/src/.libs \
+ $(NULL)