summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..ffb157e
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,35 @@
+NULL =
+
+RDA_LIB = -lrda
+
+TESTS =
+DISTCLEANFILES =
+XFAIL_TESTS =
+
+check_PROGRAMS =
+
+#############################
+# Test Loader
+#############################
+
+check_PROGRAMS += test-x2go
+
+test_x2go_SOURCES = \
+ test-x2go.c
+
+test_x2go_CFLAGS = \
+ -Wall -Werror \
+ $(LIBRDA_CFLAGS) \
+ $(LIBRDA_TESTS_CFLAGS) \
+ -I$(top_srcdir) \
+ -DBUILD_DIR="\"$(builddir)\"" \
+ $(NULL)
+
+
+test_x2go_LDADD = \
+ $(LIBRDA_LIBS) \
+ $(LIBRDA_TESTS_LIBS) \
+ -L$(top_builddir)/src/.libs \
+ $(NULL)
+
+TESTS += test-x2go