aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-08-17 22:52:59 -0500
committerTed Gould <ted@gould.cx>2012-08-17 22:52:59 -0500
commit63478d8c9d66586cb8869383cf601af0fe294e9e (patch)
treef0719a26de5b5b79e66dccb44f679d9f81b354fd /Makefile.am
parent24f787b5d2af756fe8bb02ef1fed53bf51c0305a (diff)
downloadlightdm-remote-session-freerdp2-63478d8c9d66586cb8869383cf601af0fe294e9e.tar.gz
lightdm-remote-session-freerdp2-63478d8c9d66586cb8869383cf601af0fe294e9e.tar.bz2
lightdm-remote-session-freerdp2-63478d8c9d66586cb8869383cf601af0fe294e9e.zip
Adding in the session configuration
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 51fd14b..3ac226a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,8 +3,19 @@ pam_sessiondir = $(sysconfdir)/pam.d/
pam_session_DATA = \
lightdm-remote-freerdp
+lightdm_sessiondir = $(datadir)/lightdm/remote-sessions
+lightdm_session_DATA = \
+ freerdp.desktop
+
+%.desktop: %.desktop.in
+ @sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+
EXTRA_DIST = \
- $(pam_session_DATA)
+ $(pam_session_DATA) \
+ freerdp.desktop.in
+
+CLEANFILES = \
+ freerdp.desktop
DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall