aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-08-17 22:21:15 -0500
committerTed Gould <ted@gould.cx>2012-08-17 22:21:15 -0500
commitb038ae42051de65da8cdf8baf44f1b7bf5583365 (patch)
tree5a6f3d5b913831b77502ee60cdaeb7bb3dfa6554 /configure.ac
downloadlightdm-remote-session-freerdp2-b038ae42051de65da8cdf8baf44f1b7bf5583365.tar.gz
lightdm-remote-session-freerdp2-b038ae42051de65da8cdf8baf44f1b7bf5583365.tar.bz2
lightdm-remote-session-freerdp2-b038ae42051de65da8cdf8baf44f1b7bf5583365.zip
Base build system
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f4f235e
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,31 @@
+AC_INIT([lightdm-remote-session-freerdp], [0.0.1])
+
+AM_INIT_AUTOMAKE([1.11 -Wno-portability])
+AM_SILENT_RULES([yes])
+
+###########################
+# Local Install
+###########################
+
+with_localinstall="no"
+AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall],
+ [install all files locally (for distcheck)]),
+ with_localinstall=$enableval,
+ with_localinstall=no)
+
+###########################
+# PAM Module dir
+###########################
+
+if test "x$with_localinstall" = "xyes"; then
+ PAMMODULEDIR="${libdir}/security/"
+else
+ PAMMODULEDIR="/lib/security"
+fi
+AC_SUBST(PAMMODULEDIR)
+
+
+AC_CONFIG_FILES([
+ Makefile
+])
+AC_OUTPUT