aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-08-29 16:35:47 -0500
committerTed Gould <ted@gould.cx>2012-08-29 16:35:47 -0500
commit58791bb4a55905588ed5378948ce536523b331a8 (patch)
tree90b9be2466d6597accc81cba2083bf36c4b6f82c /Makefile.am
parent898c43cef8d4e57740227743794700f0d7fa2ca2 (diff)
downloadlightdm-remote-session-x2go-58791bb4a55905588ed5378948ce536523b331a8.tar.gz
lightdm-remote-session-x2go-58791bb4a55905588ed5378948ce536523b331a8.tar.bz2
lightdm-remote-session-x2go-58791bb4a55905588ed5378948ce536523b331a8.zip
Compiling with PIE
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index df8fa8e..bf4b300 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,6 +22,11 @@ pkglibexec_PROGRAMS = \
socket-sucker
socket_sucker_SOURCES = \
socket-sucker.c
+socket_sucker_CFLAGS = \
+ -Wall -Werror \
+ -fPIE
+socket_sucker_LDFLAGS = \
+ -pie
EXTRA_DIST = \
$(pam_session_DATA) \