aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2016-06-23 14:27:15 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2016-07-01 13:09:21 +0200
commitd650a0b47eadeb675e2d2cf03ad10a4dbc564971 (patch)
tree5ae7d463f5a67ddb3a35f0ab86fc225c386513a3 /debian/rules
parent4cbfc5f98ea8311b0f01bcf2c219fd42c80adccd (diff)
downloadnx-libs-d650a0b47eadeb675e2d2cf03ad10a4dbc564971.tar.gz
nx-libs-d650a0b47eadeb675e2d2cf03ad10a4dbc564971.tar.bz2
nx-libs-d650a0b47eadeb675e2d2cf03ad10a4dbc564971.zip
OPTFLAGS: Properly propagate build option flags to nxcomp{,ext,shad} and the nx-X11 build scripts.
Note: - The "normal" way to inject CFLAGS (and CPPFLAGS) into nx-X11 builds is copying those options over into the variable CDEBUGFLAGS. - LDFLAGS have to be handed to nx-X11 via LOCAL_LDFLAGS. This change also includes a slight change in the nx-X11 build order. Old build order: Main Makefile: - [...] - libNX_X11 + implicitly building nxcomp + implicitly building nxcompext - [...] - nxagent + implicitly building nxcompshad - [...] New build ordner: Main Makefile: - [...] - nxcomp - setup nx-X11 build env + cd nx-X11 && make BuildEnv - nx-X11/lib/* - nxcompext - nxcompshad - [...] - nxagent - [...] Fixes ArcticaProject/nx-libs#141 Fixes X2GoBTS#84
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index a37478c21..275956c9a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -66,7 +66,7 @@ override_dh_auto_install:
override_dh_auto_build:
- LOCAL_LDFLAGS="$(LDFLAGS)" SHLIBGLOBALSFLAGS="$(LDFLAGS)" SHLIBDIR="$(LIBDIR)" PREFIX=/usr dh_auto_build --parallel
+ PREFIX=/usr dh_auto_build --parallel -- CDEBUGFLAGS="$(CPPFLAGS) $(CFLAGS)" LOCAL_LDFLAGS="$(LDFLAGS)" SHLIBGLOBALSFLAGS="$(LDFLAGS)" SHLIBDIR="$(LIBDIR)"
override_dh_strip:
dh_strip -plibnx-x11-6 --dbg-package=libnx-x11-6-dbg