aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-02-09 10:37:17 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-02-09 10:37:17 +0100
commiteb55dc8fd6974ca6f3325d2d30e56c96f28d2876 (patch)
tree2b2421501c798d46479a52665202e6e616134691 /debian/rules
parent939492d83d5be30d139519367e6c8451cef95608 (diff)
downloadnx-libs-eb55dc8fd6974ca6f3325d2d30e56c96f28d2876.tar.gz
nx-libs-eb55dc8fd6974ca6f3325d2d30e56c96f28d2876.tar.bz2
nx-libs-eb55dc8fd6974ca6f3325d2d30e56c96f28d2876.zip
Drop not-used-anymore NX source tree clean-up code. Source tree has been cleaned up natively.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules26
1 files changed, 0 insertions, 26 deletions
diff --git a/debian/rules b/debian/rules
index 099050b7d..b8e4ad4e1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,14 +13,6 @@ export INCLUDEDIR = "/usr/include/$(shell dpkg-architecture -qDEB_BUILD_MULTIARC
%:
CONFIGURE="./configure --with-symbols --prefix=/usr --libdir=$(LIBDIR) --includedir=$(INCLUDEDIR)" dh $@ --with quilt
-# before build, we will remove unused code / bundled libraries (keep this in sync with roll-tarball.sh)
-UNUSED_FOLDERS = "debian/CODE-REDUCTION_CLEANUP-UNUSED"
-CLEANUP_FOLDERS = "debian/CODE-REDUCTION_CLEANUP-BRUTAL"
-UNNEEDED_BACKUPS = "debian/CODE-REDUCTION_CLEANUP-BACKUPFILES"
-PRESERVE_SYMLINKED_FILES = "debian/CODE-REDUCTION_PRESERVE-SYMLINKED"
-PRESERVE_NEEDED_FILES = "debian/CODE-REDUCTION_PRESERVE-NEEDED"
-PRESERVE_INCLUDED_FILES = "debian/CODE-REDUCTION_PRESERVE-INCLUDED"
-
override_dh_auto_clean:
rm -Rf nx-X11/.build-exports
dh_auto_clean
@@ -121,24 +113,6 @@ override_dh_auto_build:
# let's prep the libnx-xinerama1.postinst script with the value of the build systems's DEB_BUILD_MULTIARCH variable
sed debian/libnx-xinerama1.postinst.in -e 's/#DEB_BUILD_MULTIARCH#/$(DEB_BUILD_MULTIARCH)/' > debian/libnx-xinerama1.postinst
- # make a copy of code to be preserved for build
- mkdir -p .preserve
- for path in `cat $(PRESERVE_SYMLINKED_FILES)` `cat $(PRESERVE_NEEDED_FILES)` `cat $(PRESERVE_INCLUDED_FILES)`; do \
- if echo $$path | grep -E "^#.*"; then continue; fi; \
- test -d $$path && mkdir -p .preserve/$$path || mkdir -p .preserve/$$(dirname $$path); \
- cp -av $$path .preserve/$$path; \
- done
-
- # remove unused code / bundled libraries (see at the top of the debian/rules file)
- # for the exact list of files and folders
- rm -Rf `cat $(UNUSED_FOLDERS)`
- rm -Rf `cat $(CLEANUP_FOLDERS)`
- rm -Rf `cat $(UNNEEDED_BACKUPS)`
-
- # copy to-be-preserved files back into code tree
- cp -av .preserve/* .
- rm -Rf .preserve/
-
LOCAL_LDFLAGS=$(LDFLAGS) SHLIBGLOBALSFLAGS=$(LDFLAGS) SHLIBDIR=$(LIBDIR) PREFIX=/usr dh_auto_build --parallel
override_dh_strip: