aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMihai Moldovan <ionic@ionic.de>2017-12-26 04:06:40 +0100
committerMihai Moldovan <ionic@ionic.de>2017-12-30 03:36:11 +0100
commit26ab7b8a79e6c901518d9136d00b79e2905dab58 (patch)
tree5325ef20b6561773c9983a4866f4913eeb25b95d /debian
parente13e31f752c0b204f964ee1df272a6b31ce51189 (diff)
downloadnx-libs-26ab7b8a79e6c901518d9136d00b79e2905dab58.tar.gz
nx-libs-26ab7b8a79e6c901518d9136d00b79e2905dab58.tar.bz2
nx-libs-26ab7b8a79e6c901518d9136d00b79e2905dab58.zip
nxagent: implement RPATH/RUNPATH override for libX11.
As discussed in ArcticaProject/nx-libs#610, we need a way to load libNX_X11 as a fake version of libX11 into nxagent's address space. For doing so, we have to link against libX11 at build-time and specify a(n) RPATH/RUNPATH to our libX11 -> libNX_X11 compat symlinks. This commit is essentially doing a cross between options 3 and 4 discussed in the provided GH issue. We link libX11 early (before specifying -Lcompat_symlinks_dir), so that the linker finds the "real" libX11 version with the libX11 SONAME. This leads to our binary depending upon both libX11 and libNX_X11 SONAMEs. We already always added RPATH/RUNPATH, but these values are not passed down to dependent libraries. What happens at run-time is that the loader searches for a libX11 SONAME, takes RPATH/RUNPATH into account and loads our libNX_X11 library instead via the compat symlinks. This satisfies the libX11 SONAME and dependent libraries will *not* load the system libX11 version again. Debian's dpkg-shlibdeps isn't quite happy about this mismatching SONAME situation, so instruct to look the other way while we're minding our business. Fixes: ArcticaProject/nx-libs#610
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 90234c516..b2258cd58 100755
--- a/debian/rules
+++ b/debian/rules
@@ -124,5 +124,13 @@ override_dh_strip:
override_dh_makeshlibs:
dh_makeshlibs -n
+# Needed for the libX11 RUNPATH/RPATH link-time hack.
+# dh_shlibdeps will follow dependencies within binaries and choke
+# on the libX11 dependency, since the SONAME (libX11.*) used while linking
+# does not match the later detected SONAME (libNX_X11.*) obtained through
+# the libX11 -> libNX_X11 compat symlink.
+override_dh_shlibdeps:
+ dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
+
get-orig-source:
uscan --noconf --force-download --rename --download-current-version --destdir=..