aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-04-26 13:26:47 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-07-12 23:25:57 +0200
commit41ea54b0217175a4b78980671f4c6818eb66b166 (patch)
treea3c8b61e118fde6bd78a8dd8a1994d60aa08caaa /debian
parent322e39b79729bc72bd37265949a04962e427ef0a (diff)
downloadnx-libs-41ea54b0217175a4b78980671f4c6818eb66b166.tar.gz
nx-libs-41ea54b0217175a4b78980671f4c6818eb66b166.tar.bz2
nx-libs-41ea54b0217175a4b78980671f4c6818eb66b166.zip
nxproxy: Switch to autoreconf.
This also solves the last remnant of overlinking as described in GH issue #133. Fixes ArcticaProject/nx-libs#133.
Diffstat (limited to 'debian')
-rw-r--r--debian/copyright11
-rwxr-xr-xdebian/rules3
2 files changed, 8 insertions, 6 deletions
diff --git a/debian/copyright b/debian/copyright
index cce8e17dd..b08ec0335 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -2756,7 +2756,7 @@ Files: nx-X11/programs/Xserver/os/xdmcp.c
Copyright: 1989, Network Computing Devices, Inc., Mountain View, California
License: MIT~VeryOldStyle~NCD
-Files: nxproxy/Main.c
+Files: nxproxy/src/Main.c
Copyright: 2001, 2011, NoMachine, http://www.nomachine.com/.
License: GPL-2
@@ -2912,10 +2912,13 @@ Files: ChangeLog
nxcompshad/VERSION
nxcompshad/configure.in
nxcompshad/nxcompshad.pc.in
- nxproxy/Makefile.in
nxproxy/VERSION
- nxproxy/configure.in
nxproxy/man/nxproxy.1
+ nxproxy/Makefile.am
+ nxproxy/configure.ac
+ nxproxy/m4/.placeholder
+ nxproxy/man/Makefile.am
+ nxproxy/src/Makefile.am
Copyright: 2001, 2011, NoMachine (http://www.nomachine.com)
2008-2014, Oleksandr Shneyder <o.shneyder@phoca-gmbh.de>
2011-2016, Mike Gabriel <mike.gabriel@das-netzwerkteam.de>*/
@@ -2944,13 +2947,11 @@ Comment:
Contributions by Daniel Stone have been licensed under MIT~X11.
Files: nxcomp/mkinstalldirs
- nxproxy/mkinstalldirs
Copyright: *No copyright*
License: public-domain
Files: nxcomp/install-sh
nxcompshad/install-sh
- nxproxy/install-sh
Copyright: 1994, X Consortium
License: Expat~NoAdvert
Comment:
diff --git a/debian/rules b/debian/rules
index 707bdec54..1400c79bd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,10 +7,11 @@ DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
export LIBDIR = "/usr/lib/$(shell dpkg-architecture -qDEB_BUILD_MULTIARCH)"
+export LIBEXECDIR = "$(LIBDIR)/nx/bin"
export INCLUDEDIR = "/usr/include/$(shell dpkg-architecture -qDEB_BUILD_MULTIARCH)"
%:
- CONFIGURE="./configure --with-symbols --prefix=/usr --libdir=$(LIBDIR) --includedir=$(INCLUDEDIR)" dh $@ --with quilt
+ CONFIGURE="./configure --with-symbols --prefix=/usr --libdir=$(LIBDIR) --includedir=$(INCLUDEDIR) --libexecdir=$(LIBEXECDIR)" dh $@ --with quilt
override_dh_auto_clean:
rm -Rf nx-X11/.build-exports