aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-05-28 14:33:08 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-06-23 16:25:23 +0200
commit47afc48ea312b3ab7a5138c15271942103ec3fee (patch)
treebca3cae80c6faab96de7fa7dca822bd0ae876851 /debian
parent895ee3b3b1f199dae2ed4da9c393d1ba575820a0 (diff)
downloadnx-libs-47afc48ea312b3ab7a5138c15271942103ec3fee.tar.gz
nx-libs-47afc48ea312b3ab7a5138c15271942103ec3fee.tar.bz2
nx-libs-47afc48ea312b3ab7a5138c15271942103ec3fee.zip
debian/roll-tarball.sh: Prevent several files/folders from ending up in nx-libs-lite tarball.
* bin/{nxagent,nxauth,x2goagent} * etc/ * doc/nx-X11_vs_XOrg69_patches * README.keystrokes" * nx-libs.spec
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/roll-tarballs.sh13
1 files changed, 9 insertions, 4 deletions
diff --git a/debian/roll-tarballs.sh b/debian/roll-tarballs.sh
index ff777bd37..3e41092f8 100755
--- a/debian/roll-tarballs.sh
+++ b/debian/roll-tarballs.sh
@@ -87,9 +87,13 @@ if [ "x$MODE" = "xfull" ]; then
echo "${file##*/}" >> "doc/applied-patches/series"
done
else
+ rm -f "bin/"{nxagent,nxauth,x2goagent}
rm -Rf "nxcompshad"*
rm -Rf "nxcompext"*
rm -Rf "nx-X11"*
+ rm -Rf "etc"*
+ rm -Rf "doc/nx-X11_vs_XOrg69_patches"*
+ rm -f "README.keystrokes"
cat "debian/patches/series" | sort | grep -v '^#' | egrep "([0-9]+(_|-).*\.full\+lite\.patch)" | while read file
do
cp -v "debian/patches/$file" "doc/applied-patches/"
@@ -104,15 +108,16 @@ else
echo "No patches applied at all. Very old release?"
fi
+# remove folders that we do not want to roll into the tarball
+rm -Rf ".pc/"
+rm -Rf "debian/"
+rm -Rf "nx-libs.spec"
+
# very old release did not add any README
for f in $(ls README* 2>/dev/null); do
mv -v "$f" "doc/";
done
-# remove folders that we do not want to roll into the tarball
-rm -Rf ".pc/"
-rm -Rf "debian/"
-
# remove files, that we do not want in the tarballs (build cruft)
rm -Rf nx*/configure nx*/autom4te.cache*