aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-05-24 09:05:55 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-05-24 09:05:55 +0200
commit7cb00355c66248381120dae69f2658ede64b0417 (patch)
treef93f32e3f8c6473fbd0f36117301a94d2b9b6536 /debian
parent11b534ab008f9f0ac831d96f0426adf4c3561319 (diff)
downloadnx-libs-7cb00355c66248381120dae69f2658ede64b0417.tar.gz
nx-libs-7cb00355c66248381120dae69f2658ede64b0417.tar.bz2
nx-libs-7cb00355c66248381120dae69f2658ede64b0417.zip
debian/rules: Highly enforce --no-parallel mode while Xserver is still on imake. Can be re-parallelized after autotools conversion.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index f5f7c5ba0..82564dbee 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,7 +19,7 @@ export INCLUDEDIR = "/usr/include/$(DEB_HOST_MULTIARCH)"
--includedir=$(INCLUDEDIR) \
--libexecdir=$(LIBEXECDIR) \
--build=$(DEB_BUILD_GNU_TYPE) \
- --host=$(DEB_HOST_GNU_TYPE)" dh $@ --with quilt
+ --host=$(DEB_HOST_GNU_TYPE)" dh $@ --no-parallel --with quilt
override_dh_auto_clean:
rm -Rf nx-X11/.build-exports
@@ -47,11 +47,11 @@ override_dh_install:
dh_install --fail-missing
override_dh_auto_install:
- PREFIX=/usr dh_auto_install -Smakefile
+ PREFIX=/usr dh_auto_install --no-parallel -Smakefile
override_dh_auto_build:
debian/compat.sh
- PREFIX=/usr dh_auto_build --parallel -- CDEBUGFLAGS="$(CPPFLAGS) $(CFLAGS)" LOCAL_LDFLAGS="$(LDFLAGS)" SHLIBGLOBALSFLAGS='$(filter-out -pie,$(LDFLAGS))'
+ PREFIX=/usr dh_auto_build ---no-parallel -- CDEBUGFLAGS="$(CPPFLAGS) $(CFLAGS)" LOCAL_LDFLAGS="$(LDFLAGS)" SHLIBGLOBALSFLAGS='$(filter-out -pie,$(LDFLAGS))'
override_dh_strip:
dh_strip -plibnx-x11-6 --dbg-package=libnx-x11-6-dbg