aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-04-25 18:40:55 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-04-25 18:40:55 +0200
commit94d77e27a7331cd54158ad0bd95f22df22e4dba1 (patch)
tree03358cc3ea1a0640c811e00dbb7ef43e373fc4fd /debian
parentda4770474c6b9aab49242d0012dfd4497250b484 (diff)
downloadnx-libs-94d77e27a7331cd54158ad0bd95f22df22e4dba1.tar.gz
nx-libs-94d77e27a7331cd54158ad0bd95f22df22e4dba1.tar.bz2
nx-libs-94d77e27a7331cd54158ad0bd95f22df22e4dba1.zip
debian/rules: Avoid dh_auto_build. It adds -Oline since 11.2 which let's make choke in nx-X11/ subdir on the Makefiles target. Reason unknown.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index dffab72b5..4ecb63f67 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,10 @@ export LIBDIR = "/usr/lib/$(DEB_HOST_MULTIARCH)"
export LIBEXECDIR = "$(LIBDIR)/nx/bin"
export INCLUDEDIR = "/usr/include/$(DEB_HOST_MULTIARCH)"
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+endif
+
%:
CONFIGURE="./configure --disable-silent-rules \
--prefix=/usr \
@@ -116,7 +120,7 @@ override_dh_auto_install:
override_dh_auto_build:
debian/compat.sh
- PREFIX=/usr dh_auto_build --parallel -- CDEBUGFLAGS="$(CPPFLAGS) $(CFLAGS)" LOCAL_LDFLAGS="$(LDFLAGS)" SHLIBGLOBALSFLAGS='$(filter-out -pie,$(LDFLAGS))'
+ PREFIX=/usr make build -j${NUM_JOBS} CDEBUGFLAGS="$(CPPFLAGS) $(CFLAGS)" LOCAL_LDFLAGS="$(LDFLAGS)" SHLIBGLOBALSFLAGS='$(filter-out -pie,$(LDFLAGS))'
override_dh_strip:
dh_strip -plibnx-x11-6 --dbg-package=libnx-x11-6-dbg