aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-07-14 20:39:58 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-07-14 20:53:19 +0200
commitc2761fb7c7dc497e48ba51b0943c7c369efef5e7 (patch)
tree220436cbeeabc6acc9c1f6ece4dd7450ab19ad00 /debian
parentc1d502e1cfa8f3c2b05c7549c931831bf3b2a483 (diff)
downloadnx-libs-c2761fb7c7dc497e48ba51b0943c7c369efef5e7.tar.gz
nx-libs-c2761fb7c7dc497e48ba51b0943c7c369efef5e7.tar.bz2
nx-libs-c2761fb7c7dc497e48ba51b0943c7c369efef5e7.zip
roll-tarball.sh: Make sure symlinked files are included in tarballs.
As the system a tarball gets extracted on may potentially be unable to handle symlinks, we ship symlinks as files in the rolled tarball. By transforming symlinks into real files, we also assure that all VERSION files/symlinks get shipped in the tarballs. Fixes ArcticaProject/nx-libs#27
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/roll-tarballs.sh18
1 files changed, 15 insertions, 3 deletions
diff --git a/debian/roll-tarballs.sh b/debian/roll-tarballs.sh
index ecaeac2e0..2fba5a042 100755
--- a/debian/roll-tarballs.sh
+++ b/debian/roll-tarballs.sh
@@ -78,6 +78,20 @@ echo "Created tarball for $CHECKOUT"
cd "${TEMP_DIR}/${PROJECT}-${RELEASE}/"
+set -x
+# Replace symlinks by copies of the linked target files
+# Note: We don't have symlinked directories!!!
+find . -type l | while read link; do
+ TARGET=$(readlink "$link")
+ cd $(dirname $link)
+ if [ -f "$TARGET" ]; then
+ rm -f $(basename $link)
+ cp ${TARGET} $(basename $link)
+ fi
+ cd - 1>/dev/null
+done
+set +x
+
mkdir -p "doc/applied-patches"
# prepare patches for lite and full tarball
@@ -95,6 +109,7 @@ else
rm -Rf "etc"*
rm -Rf "doc/nx-X11_vs_XOrg69_patches"*
rm -f "README.keystrokes"
+ rm -f "VERSION.x2goagent"
cat "debian/patches/series" | sort | grep -v '^#' | egrep "([0-9]+(_|-).*\.full\+lite\.patch)" | while read file
do
cp -v "debian/patches/$file" "doc/applied-patches/"
@@ -114,9 +129,6 @@ rm -Rf ".pc/"
rm -Rf "debian/"
rm -Rf "nx-libs.spec"
-# some file renamings
-mv README.md README.NX-Development
-
# very old release did not add any README
for f in $(ls README* 2>/dev/null); do
mv -v "$f" "doc/";