aboutsummaryrefslogtreecommitdiff
path: root/nx-libs.spec
diff options
context:
space:
mode:
authorMihai Moldovan <ionic@ionic.de>2018-06-17 01:32:58 +0200
committerMihai Moldovan <ionic@ionic.de>2018-06-17 01:33:01 +0200
commitda51a36948be6b5cfc200772bf5e51f8545ca4c3 (patch)
tree1295c29ac770bdd929e83b22c37cd54d3e6c60e6 /nx-libs.spec
parent942ae190ef03c241b9c82830597d1c2bbe361035 (diff)
downloadnx-libs-da51a36948be6b5cfc200772bf5e51f8545ca4c3.tar.gz
nx-libs-da51a36948be6b5cfc200772bf5e51f8545ca4c3.tar.bz2
nx-libs-da51a36948be6b5cfc200772bf5e51f8545ca4c3.zip
nx-libs.spec: disable parallel builds, was pure luck that it worked before.
What actually happened was that MFLAGS were passed-through more correctly, which forced make into jobserver mode (due to the inclusion of --jobserver-fds=... in %{_smp_mflags}), but the processes were not able to read from their FD's, so it defaulted to non-parallel builds instead.
Diffstat (limited to 'nx-libs.spec')
-rw-r--r--nx-libs.spec2
1 files changed, 1 insertions, 1 deletions
diff --git a/nx-libs.spec b/nx-libs.spec
index 3b46d4266..8a8c2299f 100644
--- a/nx-libs.spec
+++ b/nx-libs.spec
@@ -412,7 +412,7 @@ FORCE_TIRPC='NO'
FORCE_TIRPC='YES'
%endif
IMAKE_DEFINES="-DUseTIRPC=${FORCE_TIRPC}"
-make %{?_smp_mflags} CONFIGURE="$PWD/my_configure" PREFIX=%{_prefix} LIBDIR=%{_libdir} CDEBUGFLAGS="${CDEBUGFLAGS}" LOCAL_LDFLAGS="${LOCAL_LDFLAGS}" SHLIBGLOBALSFLAGS="${SHLIBGLOBALSFLAGS}" IMAKE_DEFINES="${IMAKE_DEFINES}"
+make CONFIGURE="$PWD/my_configure" PREFIX=%{_prefix} LIBDIR=%{_libdir} CDEBUGFLAGS="${CDEBUGFLAGS}" LOCAL_LDFLAGS="${LOCAL_LDFLAGS}" SHLIBGLOBALSFLAGS="${SHLIBGLOBALSFLAGS}" IMAKE_DEFINES="${IMAKE_DEFINES}"
%install
make install \