aboutsummaryrefslogtreecommitdiff
path: root/nxcomp/configure.ac
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-08-03 10:22:55 -0400
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-08-08 07:53:55 -0400
commit4fd038dba6f9b4d87c0e14fa5ff59abbcd46e794 (patch)
treeb95fcb44e2f0b7203eb78457646308c2df61485e /nxcomp/configure.ac
parent430ae6eb6c4659f3bd907ceb84b7b7bcaf65071b (diff)
downloadnx-libs-4fd038dba6f9b4d87c0e14fa5ff59abbcd46e794.tar.gz
nx-libs-4fd038dba6f9b4d87c0e14fa5ff59abbcd46e794.tar.bz2
nx-libs-4fd038dba6f9b4d87c0e14fa5ff59abbcd46e794.zip
nxcomp/configure.ac: Don't rely on pkg-config alone when it comes to testing for presence of libjpeg shared lib and header files.
Especially systems still using the IJG libjpeg implementation are likely to lack the libjpeg.pc file. . So this adds some alternative way of detecting if all libjpeg related build-dependencies are in place.
Diffstat (limited to 'nxcomp/configure.ac')
-rw-r--r--nxcomp/configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/nxcomp/configure.ac b/nxcomp/configure.ac
index 42407c6fd..4f2831c04 100644
--- a/nxcomp/configure.ac
+++ b/nxcomp/configure.ac
@@ -25,10 +25,6 @@ AC_SUBST([COMP_VERSION])
LT_COMP_VERSION=[`echo $COMP_VERSION | sed -r -e 's/^([0-9]+\.[0-9]+\.[0-9]+).*$/\1/' -e 's/\./:/g'`]
AC_SUBST([LT_COMP_VERSION])
-PKG_CHECK_MODULES(JPEG, libjpeg)
-PKG_CHECK_MODULES(PNG, libpng)
-PKG_CHECK_MODULES(Z, zlib)
-
# Upstream's pkg.m4 (since 0.27) offers this now, but define our own
# compatible version in case the local version of pkgconfig isn't new enough.
# https://bugs.freedesktop.org/show_bug.cgi?id=48743
@@ -39,6 +35,10 @@ m4_ifdef([PKG_INSTALLDIR], [PKG_INSTALLDIR],
[],[with_pkgconfigdir='$(libdir)/pkgconfig'])
AC_SUBST([pkgconfigdir], [${with_pkgconfigdir}])])
+PKG_CHECK_MODULES([JPEG], [libjpeg], [], [LIBJPEG_FALLBACK_CHECK])
+PKG_CHECK_MODULES([PNG], [libpng], [], [])
+PKG_CHECK_MODULES([Z], [zlib], [], [])
+
AC_LANG([C++])
NX_COMPILER_BRAND
NX_COMPILER_FLAGS