aboutsummaryrefslogtreecommitdiff
path: root/nxcomp/configure.ac
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-07-14 11:43:05 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-07-26 10:12:43 +0200
commit9fa0a6b954e3893f81aff1851c8e363eb0ccb98b (patch)
treeac5e301ad7f16d7588d226debd606b146b47268d /nxcomp/configure.ac
parentf76c82403888bb498973ec974dbfd20e4edb02fe (diff)
downloadnx-libs-9fa0a6b954e3893f81aff1851c8e363eb0ccb98b.tar.gz
nx-libs-9fa0a6b954e3893f81aff1851c8e363eb0ccb98b.tar.bz2
nx-libs-9fa0a6b954e3893f81aff1851c8e363eb0ccb98b.zip
nxcomp/configure.ac: Re-add previously available configure options --with-valgrind and --with-info as renamed options --enable-valgrind and --enable-debug.
Diffstat (limited to 'nxcomp/configure.ac')
-rw-r--r--nxcomp/configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/nxcomp/configure.ac b/nxcomp/configure.ac
index 87087f32d..9d44a6991 100644
--- a/nxcomp/configure.ac
+++ b/nxcomp/configure.ac
@@ -74,6 +74,20 @@ else
CPPFLAGS="$CPPFLAGS -DIN_ADDR_T=in_addr_t"
fi
+AC_ARG_ENABLE(info,
+ [AS_HELP_STRING([--enable-debug], [enable to get info session log output (disabled by default)])],
+ [if test x$enableval = xyes; then
+ AC_DEFINE(INFO, 1, [Define this to get info session log output.])
+ info_messages=yes
+ fi])
+
+AC_ARG_ENABLE(valgrind,
+ [AS_HELP_STRING([--enable-valgrind], [enable for extra valgrind hacks (disabled by default)])],
+ [if test x$enableval = xyes; then
+ AC_DEFINE(VALGRIND, 1, [Define this for extra valgrind hacks.])
+ valgrind_hacks=yes
+ fi])
+
AC_CONFIG_FILES([
Makefile
src/Makefile