aboutsummaryrefslogtreecommitdiff
path: root/nxcompshad/configure.ac
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-04-25 15:27:17 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-07-13 11:38:42 +0200
commit76b48676844bc7aa0511b8371ef6347b2e8ad545 (patch)
tree6c81a895407116ca2e3f1522c81e5d1d7122fd01 /nxcompshad/configure.ac
parent622360ea2ec9cde354aece445e4b9fb4b7664eea (diff)
downloadnx-libs-76b48676844bc7aa0511b8371ef6347b2e8ad545.tar.gz
nx-libs-76b48676844bc7aa0511b8371ef6347b2e8ad545.tar.bz2
nx-libs-76b48676844bc7aa0511b8371ef6347b2e8ad545.zip
nxcompshad: Switch to autoreconf.
Diffstat (limited to 'nxcompshad/configure.ac')
-rw-r--r--nxcompshad/configure.ac53
1 files changed, 53 insertions, 0 deletions
diff --git a/nxcompshad/configure.ac b/nxcompshad/configure.ac
new file mode 100644
index 000000000..b3abf0efb
--- /dev/null
+++ b/nxcompshad/configure.ac
@@ -0,0 +1,53 @@
+dnl ***************************************************************************
+dnl *** configure.ac for nxcompshad ***
+dnl ***************************************************************************
+
+m4_define([nxcompshad_version], m4_esyscmd([tr -d '\n' < VERSION]))
+
+# Initialize Autoconf
+AC_PREREQ(2.60)
+
+AC_INIT([libXcompshad], [nxcompshad_version], [https://github.com/ArcticaProject/nx-libs/issues])
+AC_PROG_CXX
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_AUX_DIR([build-aux])
+
+AM_INIT_AUTOMAKE([foreign no-dist-gzip dist-xz])
+
+# Initialize libtool
+AC_PROG_LIBTOOL
+
+COMPSHAD_VERSION=nxcompshad_version
+AC_SUBST([COMPSHAD_VERSION])
+
+LT_COMPSHAD_VERSION=[`echo $COMPSHAD_VERSION | sed -r -e 's/^([0-9]+\.[0-9]+\.[0-9]+).*$/\1/' -e 's/\./:/g'`]
+AC_SUBST([LT_COMPSHAD_VERSION])
+
+PKG_CHECK_MODULES(Xext, xext)
+PKG_CHECK_MODULES(Xdamage, xdamage)
+PKG_CHECK_MODULES(Xrandr, xrandr)
+PKG_CHECK_MODULES(Xtst, xtst)
+
+# Upstream's pkg.m4 (since 0.27) offers this now, but define our own
+# compatible version in case the local version of pkgconfig isn't new enough.
+# https://bugs.freedesktop.org/show_bug.cgi?id=48743
+m4_ifdef([PKG_INSTALLDIR], [PKG_INSTALLDIR],
+ [AC_ARG_WITH([pkgconfigdir],
+ [AS_HELP_STRING([--with-pkgconfigdir],
+ [install directory for nxcompshad.pc pkg-config file])],
+ [],[with_pkgconfigdir='$(libdir)/pkgconfig'])
+ AC_SUBST([pkgconfigdir], [${with_pkgconfigdir}])])
+
+AC_LANG([C++])
+NX_COMPILER_BRAND
+NX_COMPILER_FLAGS
+
+AC_CONFIG_FILES([
+Makefile
+src/Makefile
+nxcompshad.pc
+])
+
+AC_OUTPUT