aboutsummaryrefslogtreecommitdiff
path: root/nxcompshad/configure.in
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2016-06-23 14:27:15 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2016-07-01 13:09:21 +0200
commitd650a0b47eadeb675e2d2cf03ad10a4dbc564971 (patch)
tree5ae7d463f5a67ddb3a35f0ab86fc225c386513a3 /nxcompshad/configure.in
parent4cbfc5f98ea8311b0f01bcf2c219fd42c80adccd (diff)
downloadnx-libs-d650a0b47eadeb675e2d2cf03ad10a4dbc564971.tar.gz
nx-libs-d650a0b47eadeb675e2d2cf03ad10a4dbc564971.tar.bz2
nx-libs-d650a0b47eadeb675e2d2cf03ad10a4dbc564971.zip
OPTFLAGS: Properly propagate build option flags to nxcomp{,ext,shad} and the nx-X11 build scripts.
Note: - The "normal" way to inject CFLAGS (and CPPFLAGS) into nx-X11 builds is copying those options over into the variable CDEBUGFLAGS. - LDFLAGS have to be handed to nx-X11 via LOCAL_LDFLAGS. This change also includes a slight change in the nx-X11 build order. Old build order: Main Makefile: - [...] - libNX_X11 + implicitly building nxcomp + implicitly building nxcompext - [...] - nxagent + implicitly building nxcompshad - [...] New build ordner: Main Makefile: - [...] - nxcomp - setup nx-X11 build env + cd nx-X11 && make BuildEnv - nx-X11/lib/* - nxcompext - nxcompshad - [...] - nxagent - [...] Fixes ArcticaProject/nx-libs#141 Fixes X2GoBTS#84
Diffstat (limited to 'nxcompshad/configure.in')
-rw-r--r--nxcompshad/configure.in12
1 files changed, 8 insertions, 4 deletions
diff --git a/nxcompshad/configure.in b/nxcompshad/configure.in
index 7ec064cc6..226b13ef8 100644
--- a/nxcompshad/configure.in
+++ b/nxcompshad/configure.in
@@ -10,8 +10,12 @@ AC_SUBST(pkgconfigdir)
dnl Reset default compilation flags.
-CXXFLAGS="$CXXFLAGS -O3"
-CPPFLAGS="$CPPFLAGS -O3"
+if test "x$CXXFLAGS" == "x"; then
+ CXXFLAGS="-O3"
+fi
+if test "x$CPPFLAGS" == "x"; then
+ CPPFLAGS="-O3"
+fi
dnl Reset default linking directives.
@@ -80,8 +84,8 @@ case "${gcc_version}" in
*)
AC_MSG_RESULT([yes])
- CXXFLAGS="$CXXFLAGS -Wmissing-declarations -Wnested-externs"
- CPPFLAGS="$CPPFLAGS -Wmissing-declarations -Wnested-externs"
+ CXXFLAGS="$CXXFLAGS -Wmissing-declarations"
+ CPPFLAGS="$CPPFLAGS -Wmissing-declarations"
;;
esac