aboutsummaryrefslogtreecommitdiff
path: root/nxcompshad/src/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-04-25 15:27:17 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-07-13 11:38:42 +0200
commit76b48676844bc7aa0511b8371ef6347b2e8ad545 (patch)
tree6c81a895407116ca2e3f1522c81e5d1d7122fd01 /nxcompshad/src/Makefile.am
parent622360ea2ec9cde354aece445e4b9fb4b7664eea (diff)
downloadnx-libs-76b48676844bc7aa0511b8371ef6347b2e8ad545.tar.gz
nx-libs-76b48676844bc7aa0511b8371ef6347b2e8ad545.tar.bz2
nx-libs-76b48676844bc7aa0511b8371ef6347b2e8ad545.zip
nxcompshad: Switch to autoreconf.
Diffstat (limited to 'nxcompshad/src/Makefile.am')
-rw-r--r--nxcompshad/src/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/nxcompshad/src/Makefile.am b/nxcompshad/src/Makefile.am
new file mode 100644
index 000000000..c7f45ba27
--- /dev/null
+++ b/nxcompshad/src/Makefile.am
@@ -0,0 +1,45 @@
+NULL =
+
+lib_LTLIBRARIES = libXcompshad.la
+
+libXcompshad_la_SOURCES = \
+ Core.cpp \
+ Input.cpp \
+ Logger.cpp \
+ Manager.cpp \
+ Shadow.cpp \
+ Updater.cpp \
+ Win.cpp \
+ X11.cpp \
+ $(NULL)
+
+libXcompshad_la_LIBADD = \
+ @Xext_LIBS@ \
+ @Xdamage_LIBS@ \
+ @Xrandr_LIBS@ \
+ @Xtst_LIBS@ \
+ -L$(top_srcdir)/../nx-X11/exports/lib -lNX_X11 \
+ $(NULL)
+
+AM_CFLAGS = \
+ $(Xext_CFLAGS) \
+ $(Xdamage_CFLAGS) \
+ $(Xrandr_CFLAGS) \
+ $(Xtst_CFLAGS) \
+ $(NULL)
+
+AM_CXXFLAGS = \
+ $(BASE_CXXFLAGS) \
+ $(NULL)
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/../nx-X11/exports/include \
+ $(NULL)
+
+libXcompshad_la_LDFLAGS = -version-number @LT_COMPSHAD_VERSION@ -no-undefined
+
+libXcompshadincludedir = $(includedir)/nx
+libXcompshadinclude_HEADERS = \
+ $(top_srcdir)/include/Shadow.h \
+ $(NULL)