aboutsummaryrefslogtreecommitdiff
path: root/nxproxy/src/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-04-26 13:26:47 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-07-12 23:25:57 +0200
commit41ea54b0217175a4b78980671f4c6818eb66b166 (patch)
treea3c8b61e118fde6bd78a8dd8a1994d60aa08caaa /nxproxy/src/Makefile.am
parent322e39b79729bc72bd37265949a04962e427ef0a (diff)
downloadnx-libs-41ea54b0217175a4b78980671f4c6818eb66b166.tar.gz
nx-libs-41ea54b0217175a4b78980671f4c6818eb66b166.tar.bz2
nx-libs-41ea54b0217175a4b78980671f4c6818eb66b166.zip
nxproxy: Switch to autoreconf.
This also solves the last remnant of overlinking as described in GH issue #133. Fixes ArcticaProject/nx-libs#133.
Diffstat (limited to 'nxproxy/src/Makefile.am')
-rw-r--r--nxproxy/src/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/nxproxy/src/Makefile.am b/nxproxy/src/Makefile.am
new file mode 100644
index 000000000..5ec1f9401
--- /dev/null
+++ b/nxproxy/src/Makefile.am
@@ -0,0 +1,17 @@
+NULL =
+
+nxexecdir = $(libexecdir)
+
+nxexec_PROGRAMS = nxproxy
+
+nxproxy_SOURCES = \
+ Main.c \
+ $(NULL)
+
+nxproxy_LDADD = \
+ -L$(top_srcdir)/../nxcomp/ -lXcomp \
+ $(NULL)
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/../nxcomp/ \
+ $(NULL)