aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/0620_nxcompext_use-correct-library-naming-scheme-on-OS-X.full.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0620_nxcompext_use-correct-library-naming-scheme-on-OS-X.full.patch')
-rw-r--r--debian/patches/0620_nxcompext_use-correct-library-naming-scheme-on-OS-X.full.patch56
1 files changed, 0 insertions, 56 deletions
diff --git a/debian/patches/0620_nxcompext_use-correct-library-naming-scheme-on-OS-X.full.patch b/debian/patches/0620_nxcompext_use-correct-library-naming-scheme-on-OS-X.full.patch
deleted file mode 100644
index 2a2ff66cb..000000000
--- a/debian/patches/0620_nxcompext_use-correct-library-naming-scheme-on-OS-X.full.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-Description: Use the correct library naming scheme on OS X. It differs from other UNIX-based systems.
-Author: Clemens Lang <cal@macports.org>
-v2: Make sure only the first three digits are used for current_version. (Mihai Moldovan)
-
---- a/nxcompext/Makefile.in
-+++ b/nxcompext/Makefile.in
-@@ -82,9 +82,18 @@ DEPENDINCLUDES = -I/usr/include/c++ -I/
- LIBRARY = Xcompext
-
- LIBNAME = lib$(LIBRARY)
-+ifeq ($(shell uname),Darwin)
-+LIBFULL = lib$(LIBRARY).$(VERSION).dylib
-+LIBLOAD = lib$(LIBRARY).$(LIBVERSION).dylib
-+LIBSHARED = lib$(LIBRARY).dylib
-+COMP_VER = $(shell echo '$(VERSION)' | cut -d '.' -f 1-3)
-+LIBFLAGS = -install_name $(libdir)/$(LIBLOAD) -compatibility_version $(LIBVERSION) -current_version $(COMP_VER)
-+else
- LIBFULL = lib$(LIBRARY).so.$(VERSION)
- LIBLOAD = lib$(LIBRARY).so.$(LIBVERSION)
- LIBSHARED = lib$(LIBRARY).so
-+LIBFLAGS =
-+endif
- LIBARCHIVE = lib$(LIBRARY).a
-
- LIBCYGSHARED = cyg$(LIBRARY).dll
-@@ -113,7 +122,7 @@ COBJ = $(CSRC:.c=.o)
- CXXOBJ = $(CXXSRC:.cpp=.o)
-
- $(LIBFULL): $(CXXOBJ) $(COBJ)
-- $(CXX) -o $@ $(LDFLAGS) $(CXXOBJ) $(COBJ) $(LIBS)
-+ $(CXX) -o $@ $(LDFLAGS) $(LIBFLAGS) $(CXXOBJ) $(COBJ) $(LIBS)
-
- $(LIBLOAD): $(LIBFULL)
- rm -f $(LIBLOAD)
-@@ -159,8 +168,8 @@ install.lib: all
- ./mkinstalldirs $(DESTDIR)${libdir}
- ./mkinstalldirs $(DESTDIR)${includedir}/nx
- $(INSTALL_DATA) $(LIBFULL) $(DESTDIR)${libdir}
-- $(INSTALL_LINK) libXcompext.so.3 $(DESTDIR)${libdir}
-- $(INSTALL_LINK) libXcompext.so $(DESTDIR)${libdir}
-+ $(INSTALL_LINK) $(LIBLOAD) $(DESTDIR)${libdir}
-+ $(INSTALL_LINK) $(LIBSHARED) $(DESTDIR)${libdir}
- $(INSTALL_DATA) NX*.h $(DESTDIR)${includedir}/nx
- echo "Running ldconfig tool, this may take a while..." && ldconfig || true
-
-@@ -172,8 +181,8 @@ uninstall.bin:
-
- uninstall.lib:
- $(RM_FILE) $(DESTDIR)${libdir}/$(LIBFULL)
-- $(RM_FILE) $(DESTDIR)${libdir}/libXcompext.so.3
-- $(RM_FILE) $(DESTDIR)${libdir}/libXcompext.so
-+ $(RM_FILE) $(DESTDIR)${libdir}/$(LIBLOAD)
-+ $(RM_FILE) $(DESTDIR)${libdir}/$(LIBSHARED)
- $(RM_FILE) $(DESTDIR)${includedir}/nx/NXlib.h
- $(RM_FILE) $(DESTDIR)${includedir}/nx/NXlibint.h
- echo "Running ldconfig tool, this may take a while..." && ldconfig || true