aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 0 insertions, 19 deletions
diff --git a/debian/rules b/debian/rules
index e0b4166f5..b17828231 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,21 +19,12 @@ override_dh_auto_clean:
override_dh_clean:
rm -f nx*/configure
- rm -f nx*/changelog
- rm -f doc/changelog
- rm -f nx-X11/programs/Xserver/hw/nxagent/changelog
- rm -f nx-X11/programs/nxauth/changelog
. ./replace.sh; set -x; ls debian/*.install.in | while read file; do rm -f $$(string_rep $$file .install.in .install); done
rm -fR bin etc/rgb etc/keystrokes.cfg etc/nxagent.keyboard etc/x2goagent.keyboard
rm -f debian/libnx-xinerama1.postinst
rm -fR .preserve/
dh_clean
-override_dh_installchangelog:
-
- ### the doc/changelog file is the actual NX (redistributed) ChangeLog
- dh_installchangelog doc/changelog
-
override_dh_install:
# handle builds for Debian squeeze (non multi-arch)
@@ -87,22 +78,12 @@ override_dh_auto_install:
override_dh_auto_build:
- # create copies of upstream changelogs so that names apply to Debian policy...
- cp -a nx-X11/CHANGELOG nx-X11/changelog
- cp -a nxcomp/CHANGELOG nxcomp/changelog
- cp -a nxcompext/CHANGELOG nxcompext/changelog
- cp -a nxcompshad/CHANGELOG nxcompshad/changelog
- cp -a nx-X11/programs/Xserver/hw/nxagent/CHANGELOG nx-X11/programs/Xserver/hw/nxagent/changelog
- cp -a nx-X11/programs/nxauth/CHANGELOG nx-X11/programs/nxauth/changelog
- cp -a nxproxy/CHANGELOG nxproxy/changelog
ln -s debian/wrappers bin
mkdir -p etc/
ln -s ../debian/keystrokes.cfg etc/keystrokes.cfg
ln -s ../debian/rgb etc/rgb
ln -s ../debian/nxagent.keyboard etc/nxagent.keyboard
ln -s ../debian/x2goagent.keyboard etc/x2goagent.keyboard
- mkdir -p doc/
- ln -s ../debian/changelog doc/changelog
# let's prep the libnx-xinerama1.postinst script with the value of the build systems's DEB_BUILD_MULTIARCH variable
sed debian/libnx-xinerama1.postinst.in -e 's/#DEB_BUILD_MULTIARCH#/$(DEB_BUILD_MULTIARCH)/' > debian/libnx-xinerama1.postinst