aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/nxagent.postinst.in (renamed from debian/libnx-xinerama1.postinst.in)2
-rwxr-xr-xdebian/nxagent.prerm (renamed from debian/libnx-xinerama1.prerm)2
-rwxr-xr-xdebian/rules6
4 files changed, 8 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index c8ab3df60..efb0200da 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,6 +12,9 @@ nx-libs (2:3.5.0.33-0x2go1) UNRELEASED; urgency=low
+ Revert 5a9f829. Make sure libnx-Xinerama1 based Xinerama works
again with X2Go on Debian based systems.
+ Enforce symlink creation for Xinerama et al. library symlinks.
+ * Xinerama symlinking: Attach Xinerama symlinking to nxagent bin:package (and
+ not libnx-xinerama1).
+ Backported from Arctica GH 3.6.x branch.
-- X2Go Release Manager <git-admin@x2go.org> Sat, 04 Jul 2015 06:29:19 +0200
diff --git a/debian/libnx-xinerama1.postinst.in b/debian/nxagent.postinst.in
index 38cc415f4..4ad52a525 100755
--- a/debian/libnx-xinerama1.postinst.in
+++ b/debian/nxagent.postinst.in
@@ -1,5 +1,5 @@
#!/bin/sh
-# postinst script for libnx-x11
+# postinst script for nxagent
#
# see: dh_installdeb(1)
diff --git a/debian/libnx-xinerama1.prerm b/debian/nxagent.prerm
index 8cca06c85..edc882a46 100755
--- a/debian/libnx-xinerama1.prerm
+++ b/debian/nxagent.prerm
@@ -1,5 +1,5 @@
#!/bin/sh
-# prerm script for libnx-xinerama1
+# prerm script for nxagent
#
# see: dh_installdeb(1)
# summary of how this script can be called:
diff --git a/debian/rules b/debian/rules
index 6a82c674d..2cd77b383 100755
--- a/debian/rules
+++ b/debian/rules
@@ -34,7 +34,7 @@ override_dh_clean:
if [ ! -f replace.sh ] && [ ! -h replace.sh ]; then ln -s debian/Makefile.replace.sh replace.sh; fi
. ./replace.sh; set -x; ls debian/*.install.in | while read file; do rm -f $$(string_rep $$file .install.in .install); done
rm -fR replace.sh Makefile bin etc/rgb VERSION.x2goagent etc/keystrokes.cfg etc/nxagent.keyboard etc/x2goagent.keyboard
- rm -f debian/libnx-xinerama1.postinst
+ rm -f debian/nxagent.postinst
rm -fR .preserve/
if [ -f nxcomp/.VERSION.NoMachine ]; then mv nxcomp/.VERSION.NoMachine nxcomp/VERSION; fi
dh_clean
@@ -119,8 +119,8 @@ override_dh_auto_build:
ln -sf debian/VERSION VERSION.x2goagent
ln -sf ../debian/VERSION nxcomp/VERSION
- # let's prep the libnx-xinerama1.postinst script with the value of the build systems's DEB_BUILD_MULTIARCH variable
- sed debian/libnx-xinerama1.postinst.in -e 's/#DEB_BUILD_MULTIARCH#/$(DEB_BUILD_MULTIARCH)/' > debian/libnx-xinerama1.postinst
+ # let's prep the nxagent.postinst script with the value of the build systems's DEB_BUILD_MULTIARCH variable
+ sed debian/nxagent.postinst.in -e 's/#DEB_BUILD_MULTIARCH#/$(DEB_BUILD_MULTIARCH)/' > debian/nxagent.postinst
# make a copy of code to be preserved for build
mkdir -p .preserve