aboutsummaryrefslogtreecommitdiff
path: root/nxcomp/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'nxcomp/configure.ac')
-rw-r--r--nxcomp/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/nxcomp/configure.ac b/nxcomp/configure.ac
index a1839c719..0e17521c3 100644
--- a/nxcomp/configure.ac
+++ b/nxcomp/configure.ac
@@ -19,6 +19,13 @@ AM_INIT_AUTOMAKE([foreign no-dist-gzip dist-bzip2])
# Initialize libtool
AC_PROG_LIBTOOL
+# enable this to add the variable to the Makefiles
+#AC_ARG_VAR(NX_VERSION_CUSTOM, [custom version string])
+
+if test "x$NX_VERSION_CUSTOM" != x; then
+ AC_DEFINE_UNQUOTED([NX_VERSION_CUSTOM], ["${NX_VERSION_CUSTOM}"], [user provided custom version string])
+fi
+
COMP_VERSION=nxcomp_version
AC_SUBST([COMP_VERSION])