aboutsummaryrefslogtreecommitdiff
path: root/nxcomp/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'nxcomp/configure.in')
-rw-r--r--nxcomp/configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/nxcomp/configure.in b/nxcomp/configure.in
index 47b29e7bc..6586f22b2 100644
--- a/nxcomp/configure.in
+++ b/nxcomp/configure.in
@@ -10,8 +10,12 @@ AC_SUBST(pkgconfigdir)
dnl Set our default compilation flags.
-CXXFLAGS="$CXXFLAGS -O3 -fno-rtti -fno-exceptions"
-CFLAGS="$CFLAGS -O3"
+if test "x$CXXFLAGS" = "x"; then
+ CXXFLAGS="-O3 -fno-rtti -fno-exceptions"
+fi
+if test "x$CFLAGS" = "x"; then
+ CFLAGS="$CFLAGS -O3"
+fi
dnl Reset default linking directives.