aboutsummaryrefslogtreecommitdiff
path: root/nxcompext/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'nxcompext/configure.in')
-rw-r--r--nxcompext/configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/nxcompext/configure.in b/nxcompext/configure.in
index 6078851b4..70bb9d121 100644
--- a/nxcompext/configure.in
+++ b/nxcompext/configure.in
@@ -10,8 +10,12 @@ AC_SUBST(pkgconfigdir)
dnl Reset default compilation flags.
-CXXFLAGS="$CXXFLAGS -O3"
-CFLAGS="$CFLAGS -O3"
+if test "x$CXXFLAGS" = "x"; then
+ CXXFLAGS="-O3"
+fi
+if test "x$CFLAGS" == "x"; then
+ CFLAGS="-O3"
+fi
dnl Reset default linking directives.