aboutsummaryrefslogtreecommitdiff
path: root/nxcompshad/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'nxcompshad/configure.ac')
-rw-r--r--nxcompshad/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/nxcompshad/configure.ac b/nxcompshad/configure.ac
index 34b1c053c..966add584 100644
--- a/nxcompshad/configure.ac
+++ b/nxcompshad/configure.ac
@@ -44,6 +44,12 @@ AC_LANG([C++])
NX_COMPILER_BRAND
NX_DEFAULT_OPTIONS
+AC_ARG_ENABLE([cxx11],
+ [AS_HELP_STRING([--enable-cxx11],
+ [enable optional features requiring C++11 support (disabled by default)])],
+ [AS_IF([test x$enableval = xyes],
+ [AX_CXX_COMPILE_STDCXX_11([], [mandatory])])])
+
AC_CONFIG_FILES([
Makefile
src/Makefile