aboutsummaryrefslogtreecommitdiff
path: root/nxproxy/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'nxproxy/configure.ac')
-rw-r--r--nxproxy/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/nxproxy/configure.ac b/nxproxy/configure.ac
index 2ca64f61e..1345e32a3 100644
--- a/nxproxy/configure.ac
+++ b/nxproxy/configure.ac
@@ -8,6 +8,7 @@ m4_define([nxproxy_version], m4_esyscmd([tr -d '\n' < VERSION]))
AC_PREREQ(2.60)
AC_INIT([NX Proxy], [nxproxy_version], [https://github.com/ArcticaProject/nx-libs/issues])
+
AC_CONFIG_AUX_DIR([build-aux])
AC_PROG_CC
AC_CONFIG_SRCDIR([Makefile.am])
@@ -19,6 +20,13 @@ AM_INIT_AUTOMAKE([foreign no-dist-gzip dist-bzip2])
# Initialize libtool
AC_PROG_LIBTOOL
+# enable this to add the variable to the Makefiles
+#AC_ARG_VAR(NX_VERSION_CUSTOM, [custom version string])
+
+if test "x$NX_VERSION_CUSTOM" != x; then
+ AC_DEFINE_UNQUOTED([NX_VERSION_CUSTOM], ["${NX_VERSION_CUSTOM}"], [user provided custom version string])
+fi
+
PROXY_VERSION=nxproxy_version
AC_SUBST([PROXY_VERSION])