aboutsummaryrefslogtreecommitdiff
path: root/nxproxy/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'nxproxy/configure.in')
-rw-r--r--nxproxy/configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/nxproxy/configure.in b/nxproxy/configure.in
index 914e70738..268584216 100644
--- a/nxproxy/configure.in
+++ b/nxproxy/configure.in
@@ -169,4 +169,14 @@ dnl Find makedepend somewhere.
AC_SUBST(MAKEDEPEND)
MAKEDEPEND="$(which makedepend)"
+# Try to desperately find makedepend.
+# Set MAKEDEPEND to the shipped makedepend binary. This will not
+# exist in nx-libs-lite, though, in which case MAKEDEPEND
+# will stay empty.
+if test -z "${MAKEDEPEND}"; then
+ if test -x "../nx-X11/config/makedepend/makedepend"; then
+ MAKEDEPEND="../nx-X11/config/makedepend/makedepend"
+ fi
+fi
+
AC_OUTPUT(Makefile)