aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-11-01 16:02:37 +0100
committerRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-11-01 16:02:37 +0100
commit84325968c39d35b1c3833394fef390c0bf58ca67 (patch)
tree49be2f2cca68f2e4bf286906e3400907333d5543 /CMakeLists.txt
parentbf5a53e949ffe0ebcf8578a0fc9062f63527dbc9 (diff)
downloadqmenumodel-84325968c39d35b1c3833394fef390c0bf58ca67.tar.gz
qmenumodel-84325968c39d35b1c3833394fef390c0bf58ca67.tar.bz2
qmenumodel-84325968c39d35b1c3833394fef390c0bf58ca67.zip
Uses "QT_QPA_PLATFORM=minimal" to run qt tests.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d22194c..261335a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,16 +32,6 @@ endif()
add_subdirectory(libqmenumodel)
# Tests Tools
-set(XVFB_EXEC "")
-option(USE_XVFB "Uses xvfb-run with the unit tests to avoid QtWidgets tests fails without X." FALSE)
-if(USE_XVFB)
- find_program(XVFB_RUN NAMES xvfb-run)
- if (NOT ${XVFB_RUN} MATCHES "XVFB_RUN-NOTFOUND")
- set(XVFB_EXEC ${XVFB_RUN} -a)
- message(STATUS "Using xvfb-run to perform QtWidget tests.")
- endif()
-endif()
-
if(NOT DBUS_RUNNER)
message(STATUS "dbus-test-runner not found tests disabled.")
else()