aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-09-12 14:47:26 -0300
committerRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-09-12 14:47:26 -0300
commita3aa532c698c5eab037b17870275d8e27e77a498 (patch)
tree01e918b9adc2557a0e67f05221e2c36f4e65ee29 /CMakeLists.txt
parent638bcc947afe2b941d934fc3f87513f0c8565f7f (diff)
downloadqmenumodel-a3aa532c698c5eab037b17870275d8e27e77a498.tar.gz
qmenumodel-a3aa532c698c5eab037b17870275d8e27e77a498.tar.bz2
qmenumodel-a3aa532c698c5eab037b17870275d8e27e77a498.zip
Added QML documentation.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 11 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65e6fa8..fe36672 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,12 +36,16 @@ else()
add_subdirectory(tests)
endif()
+# Doc
+OPTION(GENERATE_DOC "Enable qdoc generation" OFF)
+if(GENERATE_DOC)
+ message(STATUS "QDoc enabled.")
+ find_program(QDOC_BIN qdoc3)
+ if(NOT QDOC_BIN)
+ message(FATAL_ERROR "qdoc command not found")
+ else()
+ add_subdirectory(doc)
+ endif()
+endif()
-# Tests Tools
-#if(NOT DBUS_RUNNER)
-# message(STATUS "dbus-test-runner not found tests disabled.")
-#else()
-# enable_testing()
-# add_subdirectory(tests)
-#endif()