aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-10-31 09:30:37 +0100
committerRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-10-31 09:30:37 +0100
commitd7ae33e913f04471d24f01baacb13b04e7eeb4f0 (patch)
tree1a0460ed88b5864d3385da31d575315166678bbd /debian/rules
parent0ad7c832a92d7e3fd763d6c281338243e684865f (diff)
downloadqmenumodel-d7ae33e913f04471d24f01baacb13b04e7eeb4f0.tar.gz
qmenumodel-d7ae33e913f04471d24f01baacb13b04e7eeb4f0.tar.bz2
qmenumodel-d7ae33e913f04471d24f01baacb13b04e7eeb4f0.zip
Updated debian package to use debhelper instead of cdbs.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 7 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 7e8093d..1ba4415 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,12 @@
#!/usr/bin/make -f
# -*- makefile -*-
-DEB_CMAKE_EXTRA_FLAGS = -DCMAKE_PREFIX_PATH=/opt/qt5/lib/cmake
-DEB_DH_MAKESHLIBS_ARGS_qmenumodel-qml = -Xlibqmenumodel-qml.so
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/utils.mk
-include /usr/share/cdbs/1/class/cmake.mk
+override_dh_auto_configure:
+ PATH=/opt/qt5/bin:${PATH} dh_auto_configure
+
+%:
+ dh $@ --parallel