aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-10-15 09:54:06 -0300
committerRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-10-15 09:54:06 -0300
commit5c56d1288ba905ab162246c65fffbc69a831a14e (patch)
tree5043b5daf97aa9e2bb2e87e7d5809b3a762e556e /examples/CMakeLists.txt
parente243399cba32f939eccdcb55fe093b7c57f31161 (diff)
parent5999e7a42962140b6479995d77a178186b6b2fcc (diff)
downloadqmenumodel-5c56d1288ba905ab162246c65fffbc69a831a14e.tar.gz
qmenumodel-5c56d1288ba905ab162246c65fffbc69a831a14e.tar.bz2
qmenumodel-5c56d1288ba905ab162246c65fffbc69a831a14e.zip
Merged mainline.
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
new file mode 100644
index 0000000..028c6ef
--- /dev/null
+++ b/examples/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Standalone CMakeLists.txt to generate the info-menumodel executable.
+# This is not built as part of libqmenumodel, it has to be built separately
+# and it assumes libqmenumodel-dev is installed on the system.
+
+cmake_minimum_required(VERSION 2.8.9)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+set(CMAKE_AUTOMOC ON)
+
+find_package(Qt5Core REQUIRED)
+
+include(FindPkgConfig)
+pkg_check_modules(QMENUMODEL REQUIRED qmenumodel)
+
+add_executable(info-menumodel info-menumodel.cpp)
+
+qt5_use_modules(info-menumodel Core)
+include_directories(${QMENUMODEL_INCLUDE_DIRS})
+target_link_libraries(info-menumodel ${QMENUMODEL_LDFLAGS})
+