aboutsummaryrefslogtreecommitdiff
path: root/libqmenumodel/QMenuModel/CMakeLists.txt
diff options
context:
space:
mode:
authorOlivier Tilloy <olivier.tilloy@canonical.com>2012-10-05 11:59:50 +0200
committerOlivier Tilloy <olivier.tilloy@canonical.com>2012-10-05 11:59:50 +0200
commit81dbf09d988d87f82496ba106b5f1dd2aad7967d (patch)
treed1fed43374afcd9be379998526b7de11d591e271 /libqmenumodel/QMenuModel/CMakeLists.txt
parent696fba50395807c344325af11e71ec74cf370c3d (diff)
downloadqmenumodel-81dbf09d988d87f82496ba106b5f1dd2aad7967d.tar.gz
qmenumodel-81dbf09d988d87f82496ba106b5f1dd2aad7967d.tar.bz2
qmenumodel-81dbf09d988d87f82496ba106b5f1dd2aad7967d.zip
Port to Qt5.
To compile and test, one needs to install the qt5-meta-minimal package from the Canonical Qt5 Edgers PPA (https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta1). This installs Qt5 in /opt/qt5/. cmake needs to be invoked with CMAKE_PREFIX_PATH=/opt/qt5/lib/cmake, and /opt/qt5/bin needs to be added to $PATH.
Diffstat (limited to 'libqmenumodel/QMenuModel/CMakeLists.txt')
-rw-r--r--libqmenumodel/QMenuModel/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/libqmenumodel/QMenuModel/CMakeLists.txt b/libqmenumodel/QMenuModel/CMakeLists.txt
index 5fb1d9f..1a52ea0 100644
--- a/libqmenumodel/QMenuModel/CMakeLists.txt
+++ b/libqmenumodel/QMenuModel/CMakeLists.txt
@@ -8,7 +8,7 @@ set(QMLPLUGIN_HEADERS
plugin.h
)
-qt4_wrap_cpp(QMLPLUGIN_MOC
+qt5_wrap_cpp(QMLPLUGIN_MOC
${QMLPLUGIN_HEADERS}
)
@@ -28,6 +28,8 @@ include_directories(
${GIO_INCLUDE_DIRS}
)
+qt5_use_modules(qmenumodel-qml Qml Widgets)
+
target_link_libraries(qmenumodel-qml
qmenumodel
${QT_QTCORE_LIBRARY}