aboutsummaryrefslogtreecommitdiff
path: root/tests/client/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-09-14 16:11:28 -0300
committerRenato Araujo Oliveira Filho <renato.filho@canonical.com>2012-09-14 16:11:28 -0300
commitebe349e1d96b28e31c29b3e563da1a65fb176e39 (patch)
treebe1271f3d09159fa9f1a44b96fc62cff9cb3b72e /tests/client/CMakeLists.txt
parent2b9cf1654e8eb602f70e14246c3c583962ce7254 (diff)
downloadqmenumodel-ebe349e1d96b28e31c29b3e563da1a65fb176e39.tar.gz
qmenumodel-ebe349e1d96b28e31c29b3e563da1a65fb176e39.tar.bz2
qmenumodel-ebe349e1d96b28e31c29b3e563da1a65fb176e39.zip
Created function to convert from QVariant to GVariant.
Moved QStateAction controler from QACtionGroup.
Diffstat (limited to 'tests/client/CMakeLists.txt')
-rw-r--r--tests/client/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/client/CMakeLists.txt b/tests/client/CMakeLists.txt
index 473ebcd..c427f54 100644
--- a/tests/client/CMakeLists.txt
+++ b/tests/client/CMakeLists.txt
@@ -24,6 +24,27 @@ macro(declare_test testname)
endmacro(declare_test testname)
+macro(declare_simple_test testname)
+ set(TEST_MOC_FILE ${CMAKE_CURRENT_BINARY_DIR}/${testname}.moc)
+ qt4_generate_moc(${testname}.cpp ${TEST_MOC_FILE})
+
+ add_executable(${testname} ${testname}.cpp ${TEST_MOC_FILE})
+ target_link_libraries(${testname}
+ qmenumodelcommon
+ ${QT_QTTEST_LIBRARY}
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTGUI_LIBRARY}
+ ${QT_QTDBUS_LIBRARY}
+ ${GLIB_LDFLAGS}
+ ${GIO_LDFLAGS})
+
+ add_test(${testname}
+ ${CMAKE_CURRENT_BINARY_DIR}/${testname})
+
+ set_tests_properties(${testname} PROPERTIES
+ TIMEOUT ${CTEST_TESTING_TIMEOUT})
+endmacro(declare_simple_test testname)
+
include_directories(${qmenumodelcommon_SOURCE_DIR}
${dbusmenuscript_SOURCE_DIR}
${CMAKE_CURRENT_BINARY_DIR}
@@ -45,3 +66,4 @@ declare_test(servicetest)
declare_test(menuchangestest)
declare_test(modeltest)
declare_test(actiongrouptest)
+declare_simple_test(convertertest)