aboutsummaryrefslogtreecommitdiff
path: root/tests/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/client/CMakeLists.txt')
-rw-r--r--tests/client/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/client/CMakeLists.txt b/tests/client/CMakeLists.txt
index ed2f1aa..ce8192d 100644
--- a/tests/client/CMakeLists.txt
+++ b/tests/client/CMakeLists.txt
@@ -23,6 +23,7 @@ macro(declare_test testname)
TIMEOUT ${CTEST_TESTING_TIMEOUT}
ENVIRONMENT "PYTHONPATH=${TEST_PYTHONPATH};QT_QPA_PLATFORM=minimal")
+ set(TESTS ${TESTS} ${testname})
endmacro(declare_test testname)
macro(declare_simple_test testname)
@@ -64,3 +65,14 @@ declare_test(unitymenuactiontest)
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/qmlfiles.h.in
${CMAKE_CURRENT_BINARY_DIR}/qmlfiles.h)
+
+find_package(CoverageReport)
+enable_coverage_report(
+ TARGETS
+ qmenumodel
+ FILTER
+ ${CMAKE_SOURCE_DIR}/tests/*
+ ${CMAKE_BINARY_DIR}/*
+ TESTS
+ ${TESTS}
+)