aboutsummaryrefslogtreecommitdiff
path: root/tests/script/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/script/CMakeLists.txt')
-rw-r--r--tests/script/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/script/CMakeLists.txt b/tests/script/CMakeLists.txt
index 11af44e..bf415f5 100644
--- a/tests/script/CMakeLists.txt
+++ b/tests/script/CMakeLists.txt
@@ -8,7 +8,7 @@ set(DBUSMENUSCRIPT_HEADERS
dbusmenuscript.h
)
-qt4_wrap_cpp(DBUSMENUSCRIPT_MOC
+qt5_wrap_cpp(DBUSMENUSCRIPT_MOC
${DBUSMENUSCRIPT_HEADERS}
)
@@ -27,6 +27,8 @@ include_directories(
${QT_QTDBUS_INCLUDE_DIR}
)
+qt5_use_modules(dbusmenuscript Core DBus Test)
+
target_link_libraries(dbusmenuscript
${QT_QTCORE_LIBRARY}
${QT_QTTEST_LIBRARY}