aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..c4f1a51
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+
+PY3VERS := $(shell py3versions -r)
+
+%:
+ dh $@ --with python3 --buildsystem=python_distutils
+
+override_dh_auto_clean:
+ -find . -name '*.py[co]' | xargs rm -f
+ rm -rf *.egg-info
+
+override_dh_auto_build:
+ set -ex ; for python in $(PY3VERS) ; do \
+ $$python setup.py build ; \
+ done
+
+override_dh_auto_test:
+ifeq ($(filter nocheck,$(DEB_BUILD_OPTIONS)),)
+ set -ex; for python in $(PY3VERS) ; do \
+ $$python -m unittest tccalib.tests ; \
+ done
+endif
+
+override_dh_auto_install:
+ set -ex ; for python in $(PY3VERS) ; do \
+ $$python setup.py install --root=$(CURDIR)/debian/remote-logon-config-agent --install-layout=deb; \
+ done