aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-04-29 23:44:11 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-04-29 23:44:11 +0200
commita5d4b475a4bb77d496cf48e9e2768610965c13e5 (patch)
treee2e6829cd2492a229255fc46eda7800fbb4e644f /Makefile.am
parenta38d3b5fc1a97187d8a048e5735751da476e5ac9 (diff)
downloadremote-logon-service-a5d4b475a4bb77d496cf48e9e2768610965c13e5.tar.gz
remote-logon-service-a5d4b475a4bb77d496cf48e9e2768610965c13e5.tar.bz2
remote-logon-service-a5d4b475a4bb77d496cf48e9e2768610965c13e5.zip
ChangeLog creation handled manually...
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 6 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index e3edc22..9bcf14e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,27 +10,15 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
dist-hook:
@if test -d "$(top_srcdir)/.git"; \
then \
- echo Creating ChangeLog && \
+ echo Creating AUTHORS && \
( cd "$(top_srcdir)" && \
echo '# Generated by Makefile. Do not edit.'; echo; \
- $(top_srcdir)/missing --run git --no-pager log --since "1970" --format="%ai %aN (%h) %n%n%x09*%w(68,0,10) %s%d%n") > ChangeLog.tmp \
- && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
- || (rm -f ChangeLog.tmp; \
- echo Failed to generate ChangeLog >&2 ); \
+ $(top_srcdir)/missing --run git log | grep -e "^Author:" -e "Committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
+ || (rm -f AUTHORS.tmp; \
+ echo Failed to generate AUTHORS >&2 ); \
else \
- echo Failed to generate ChangeLog: not a branch >&2; \
- fi
- @if test -d "$(top_srcdir)/.git"; \
- then \
- echo Creating AUTHORS && \
- ( cd "$(top_srcdir)" && \
- echo '# Generated by Makefile. Do not edit.'; echo; \
- $(top_srcdir)/missing --run git log | grep -e "^Author:" -e "Committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
- && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
- || (rm -f AUTHORS.tmp; \
- echo Failed to generate AUTHORS >&2 ); \
- else \
- echo Failed to generate AUTHORS: not a branch >&2; \
+ echo Failed to generate AUTHORS: not a branch >&2; \
fi
include $(top_srcdir)/Makefile.am.coverage