aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-06-11 14:32:42 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-06-11 14:32:42 +0200
commit28218030cf48c2a577755c01208fae5f4abe57a4 (patch)
tree9dd1298175dc4ff920c9a0c3a58484d7c37d4645 /src/Makefile.am
parentc6aa8ad5a37e4070387c32b684e5174612a03163 (diff)
parent32525f1769d07260102de6b483641bb106ffbd26 (diff)
downloadremote-logon-service-28218030cf48c2a577755c01208fae5f4abe57a4.tar.gz
remote-logon-service-28218030cf48c2a577755c01208fae5f4abe57a4.tar.bz2
remote-logon-service-28218030cf48c2a577755c01208fae5f4abe57a4.zip
Merge branch 'sunweaver-pr/travis-ci'
Attributes GH PR #3: https://github.com/ArcticaProject/remote-logon-service/pull/3
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6270105..d09828a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -22,6 +22,8 @@ libgenerated_la_SOURCES = \
remote-logon.h \
$(NULL)
+# no -Werror here...
+# The generation tools might lag behind the GNU C compiler's sensitivity
libgenerated_la_CFLAGS = \
$(SERVICE_CFLAGS) \
$(NULL)
@@ -57,6 +59,7 @@ libservers_la_SOURCES = \
libservers_la_CFLAGS = \
-DUCCS_QUERY_TOOL="\"remote-logon-config-agent\"" \
+ -Werror \
$(SERVICE_CFLAGS) \
$(COVERAGE_CFLAGS) \
$(NULL)
@@ -71,6 +74,7 @@ libservers_la_LDFLAGS = \
remote_logon_service_CFLAGS = \
-DDEFAULT_CONFIG_FILE="\"$(sysconfdir)/remote-logon-service.conf\"" \
+ -Werror \
$(SERVICE_CFLAGS) \
$(COVERAGE_CFLAGS) \
$(NULL)