aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-06-11 14:32:42 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-06-11 14:32:42 +0200
commit28218030cf48c2a577755c01208fae5f4abe57a4 (patch)
tree9dd1298175dc4ff920c9a0c3a58484d7c37d4645 /tests/Makefile.am
parentc6aa8ad5a37e4070387c32b684e5174612a03163 (diff)
parent32525f1769d07260102de6b483641bb106ffbd26 (diff)
downloadremote-logon-service-28218030cf48c2a577755c01208fae5f4abe57a4.tar.gz
remote-logon-service-28218030cf48c2a577755c01208fae5f4abe57a4.tar.bz2
remote-logon-service-28218030cf48c2a577755c01208fae5f4abe57a4.zip
Merge branch 'sunweaver-pr/travis-ci'
Attributes GH PR #3: https://github.com/ArcticaProject/remote-logon-service/pull/3
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a165072..61be169 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -33,6 +33,7 @@ server_test_SOURCES = \
server_test_CFLAGS = \
-I$(top_srcdir)/src \
-I$(top_builddir)/src \
+ -Werror \
$(SERVICE_CFLAGS) \
$(NULL)
@@ -78,6 +79,7 @@ dbus_interface_CFLAGS = \
-DUCCS_CONFIG_FILE="\"$(abs_srcdir)/uccs-config.conf\"" \
-DSLMOCK_CONFIG_FILE="\"$(abs_builddir)/slmock-config.conf\"" \
-DNULL_CONFIG_FILE="\"$(abs_srcdir)/null-config.conf\"" \
+ -Werror \
$(SERVICE_CFLAGS) \
$(TEST_CFLAGS) \
$(NULL)