aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index f92ad07..e3edc22 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,24 +8,24 @@ SUBDIRS = \
DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
dist-hook:
- @if test -d "$(top_srcdir)/.bzr"; \
+ @if test -d "$(top_srcdir)/.git"; \
then \
echo Creating ChangeLog && \
( cd "$(top_srcdir)" && \
echo '# Generated by Makefile. Do not edit.'; echo; \
- $(top_srcdir)/missing --run bzr log --gnu-changelog ) > ChangeLog.tmp \
+ $(top_srcdir)/missing --run git --no-pager log --since "1970" --format="%ai %aN (%h) %n%n%x09*%w(68,0,10) %s%d%n") > ChangeLog.tmp \
&& mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
|| (rm -f ChangeLog.tmp; \
echo Failed to generate ChangeLog >&2 ); \
else \
echo Failed to generate ChangeLog: not a branch >&2; \
fi
- @if test -d "$(top_srcdir)/.bzr"; \
+ @if test -d "$(top_srcdir)/.git"; \
then \
echo Creating AUTHORS && \
( cd "$(top_srcdir)" && \
echo '# Generated by Makefile. Do not edit.'; echo; \
- $(top_srcdir)/missing --run bzr log --long --levels=0 | grep -e "^\s*author:" -e "^\s*committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ $(top_srcdir)/missing --run git log | grep -e "^Author:" -e "Committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
&& mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
|| (rm -f AUTHORS.tmp; \
echo Failed to generate AUTHORS >&2 ); \