aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index afcf78b..3660b3b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,7 @@
#!/usr/bin/make -f
+BUILD_HOME=debian/build-home
+
%:
dh $@ --with autoreconf
@@ -7,6 +9,11 @@ override_dh_autoreconf:
touch ChangeLog
dh_autoreconf
+override_dh_auto_test:
+ mkdir -p $(BUILD_HOME)
+ HOME=$(BUILD_HOME) dh_auto_test
+ rm -Rfv $(BUILD_HOME)
+
override_dh_auto_clean:
if [ -s ChangeLog ]; then rm -f ChangeLog; fi
dh_auto_clean