aboutsummaryrefslogtreecommitdiff
path: root/apps/xclock/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2010-10-05 06:44:44 +0000
committermarha <marha@users.sourceforge.net>2010-10-05 06:44:44 +0000
commit51f3d1e140307561f64c47dae1d44f912accb5cf (patch)
tree9432aedd19f670b1a72a1e8b4503f286fa910102 /apps/xclock/configure.ac
parentf07afca523ad174acd3c56fc43111a09b7a5243e (diff)
downloadvcxsrv-51f3d1e140307561f64c47dae1d44f912accb5cf.tar.gz
vcxsrv-51f3d1e140307561f64c47dae1d44f912accb5cf.tar.bz2
vcxsrv-51f3d1e140307561f64c47dae1d44f912accb5cf.zip
Update to the following packages:
- glproto-1.4.12 - kbproto-1.0.5 - renderproto-0.11.1 - xclock-1.0.5 - xextproto-7.1.2 - xproto-7.0.18 - xwininfo-1.1.0
Diffstat (limited to 'apps/xclock/configure.ac')
-rw-r--r--apps/xclock/configure.ac25
1 files changed, 13 insertions, 12 deletions
diff --git a/apps/xclock/configure.ac b/apps/xclock/configure.ac
index 3b3074f48..85cef18b0 100644
--- a/apps/xclock/configure.ac
+++ b/apps/xclock/configure.ac
@@ -21,21 +21,25 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(xclock,[1.0.4], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xclock)
-AM_INIT_AUTOMAKE([dist-bzip2])
+AC_PREREQ([2.60])
+AC_INIT([xclock],
+ [1.0.5],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
+ [xclock])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros: XORG_DEFAULT_OPTIONS
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.3 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.3)
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
+XORG_DEFAULT_OPTIONS
AM_CONFIG_HEADER(config.h)
AC_PROG_CC
AC_PROG_INSTALL
-XORG_DEFAULT_OPTIONS
AC_CHECK_FUNCS([strlcpy getpid])
@@ -43,10 +47,7 @@ AC_SEARCH_LIBS([iconv], [iconv],
[AC_DEFINE(HAVE_ICONV, 1, [Define to 1 if iconv() is available.])])
dnl Required dependencies
-PKG_CHECK_MODULES(XCLOCK_X11, x11)
-PKG_CHECK_MODULES(XAW, xaw7)
-XCLOCK_CFLAGS="$XCLOCK_X11_CFLAGS $XAW_CFLAGS"
-XCLOCK_LIBS="$XCLOCK_X11_LIBS $XAW_LIBS"
+PKG_CHECK_MODULES(XCLOCK, xaw7 xmu x11)
dnl Optional dependencies
AC_ARG_WITH(xft, AC_HELP_STRING([--with-xft],[Use Xft2 and Xrender for rendering (Default is YES)]),use_xft="$withval",use_xft="try")
@@ -71,7 +72,7 @@ AC_SUBST(XCLOCK_CFLAGS)
AC_SUBST(XCLOCK_LIBS)
PKG_CHECK_MODULES(APPDEFS, xt)
-xt_appdefaultdir=$(pkg-config --variable=appdefaultdir xt)
+xt_appdefaultdir=`$PKG_CONFIG --variable=appdefaultdir xt`
AC_ARG_WITH(appdefaultdir,
AC_HELP_STRING([--with-appdefaultdir=<pathname>],
[specify directory for app-defaults files (default is autodetected)]),