aboutsummaryrefslogtreecommitdiff
path: root/fontconfig/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-07-04 13:38:47 +0200
committermarha <marha@users.sourceforge.net>2013-07-04 13:38:47 +0200
commit2ecad38adbeaa652daaab8f2a6d112921b7e74eb (patch)
treeadce02d84ceeb4be5fef88a1ba490b1294685a5b /fontconfig/configure.ac
parent28d1f604563d9c738a4c5630364d0e6b4e9b13ff (diff)
downloadvcxsrv-2ecad38adbeaa652daaab8f2a6d112921b7e74eb.tar.gz
vcxsrv-2ecad38adbeaa652daaab8f2a6d112921b7e74eb.tar.bz2
vcxsrv-2ecad38adbeaa652daaab8f2a6d112921b7e74eb.zip
fontconfig mesa libxcb git update 4 jul 2013
libxcb commit 8b6bb1a71977116d382f45eef803aedd3e313d37 libxcb/xcb-proto commit e6a246e50e62cbcba33d0e1d2371e69e6e089383 fontconfig commit d420e1df983871ab18b0f07976596fdf0ce78847 mesa commit bbd1e60198548a12be3405fc32dd39a87e8968ab
Diffstat (limited to 'fontconfig/configure.ac')
-rw-r--r--fontconfig/configure.ac50
1 files changed, 26 insertions, 24 deletions
diff --git a/fontconfig/configure.ac b/fontconfig/configure.ac
index a2b1c72f4..aeb151331 100644
--- a/fontconfig/configure.ac
+++ b/fontconfig/configure.ac
@@ -161,35 +161,37 @@ AC_LINK_IFELSE([AC_LANG_SOURCE([[
AC_MSG_RESULT([yes])
AC_DEFINE([HAVE_POSIX_FADVISE], [1], [Define to 1 if you have the 'posix_fadvise' function.])
],[AC_MSG_RESULT([no])])
-AC_MSG_CHECKING([for scandir])
-AC_LINK_IFELSE([AC_LANG_SOURCE([[
- #include <dirent.h>
- int comp(const struct dirent **, const struct dirent **);
- int comp(const struct dirent **a, const struct dirent **b) { return 0; }
- int main(void) {
- struct dirent **d;
- return scandir(".", &d, 0, &comp) >= 0;
- }
- ]])],[
- AC_MSG_RESULT([yes])
- AC_DEFINE([HAVE_SCANDIR], [1], [Define to 1 if you have the 'scandir' function.])
- ],[
- AC_LINK_IFELSE([AC_LANG_SOURCE([[
- #include <dirent.h>
- int comp(const void *, const void *);
- int comp(const void *a, const void *b) { return 0; }
- int main(void) {
- struct dirent **d;
- return scandir(".", &d, 0, &comp) >= 0;
- }
+if test "$os_win32" = "no"; then
+ AC_MSG_CHECKING([for scandir])
+ AC_LINK_IFELSE([AC_LANG_SOURCE([[
+ #include <dirent.h>
+ int comp(const struct dirent **, const struct dirent **);
+ int comp(const struct dirent **a, const struct dirent **b) { return 0; }
+ int main(void) {
+ struct dirent **d;
+ return scandir(".", &d, 0, &comp) >= 0;
+ }
]])],[
AC_MSG_RESULT([yes])
- AC_DEFINE([HAVE_SCANDIR_VOID_P], [1], [Define to 1 if you have the 'scandir' function with int (* compar)(const void *, const void *)])
+ AC_DEFINE([HAVE_SCANDIR], [1], [Define to 1 if you have the 'scandir' function.])
],[
- AC_MSG_ERROR([
+ AC_LINK_IFELSE([AC_LANG_SOURCE([[
+ #include <dirent.h>
+ int comp(const void *, const void *);
+ int comp(const void *a, const void *b) { return 0; }
+ int main(void) {
+ struct dirent **d;
+ return scandir(".", &d, 0, &comp) >= 0;
+ }
+ ]])],[
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([HAVE_SCANDIR_VOID_P], [1], [Define to 1 if you have the 'scandir' function with int (* compar)(const void *, const void *)])
+ ],[
+ AC_MSG_ERROR([
*** No scandir function available.])
+ ])
])
- ])
+fi
CFLAGS="$fc_saved_CFLAGS"
#