aboutsummaryrefslogtreecommitdiff
path: root/fontconfig/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2012-07-06 09:12:35 +0200
committermarha <marha@users.sourceforge.net>2012-07-06 09:13:41 +0200
commit336bad93d146931c160d8517edfdf0bee49ad9f7 (patch)
treed0fbdb5a716e78aa6318c7ddd49bd3e09e13379f /fontconfig/configure.ac
parentfc8f37239f3af088819c18f5632b2608954af73a (diff)
downloadvcxsrv-336bad93d146931c160d8517edfdf0bee49ad9f7.tar.gz
vcxsrv-336bad93d146931c160d8517edfdf0bee49ad9f7.tar.bz2
vcxsrv-336bad93d146931c160d8517edfdf0bee49ad9f7.zip
randrproto fontconfig mesa xserver git update 6 Jul 2012
Diffstat (limited to 'fontconfig/configure.ac')
-rw-r--r--fontconfig/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/fontconfig/configure.ac b/fontconfig/configure.ac
index 644fc1a58..140cb70aa 100644
--- a/fontconfig/configure.ac
+++ b/fontconfig/configure.ac
@@ -353,6 +353,18 @@ if test "$enable_libxml2" = "yes"; then
AC_SUBST(LIBXML2_CFLAGS)
AC_SUBST(LIBXML2_LIBS)
+
+ fc_saved_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $LIBXML2_CFLAGS"
+ AC_MSG_CHECKING([SAX1 support in libxml2])
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include <libxml/xmlversion.h>
+ #if !defined(LIBXML_SAX1_ENABLED)
+ # include "error: No SAX1 support in libxml2"
+ #endif
+ ]])], [AC_MSG_RESULT([found])], [AC_MSG_ERROR([
+*** SAX1 support in libxml2 is required. enable it or use expat instead.])])
+ CFLAGS="$fc_saved_CFLAGS"
fi
#